Intermittent Platform Outage

Incident Report for RevolutionParts, Inc

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 11:06 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2026 - 10:34 MST

Investigating

We've identified issues with webstores displaying "502 Bad Gateway" and affected sites are inaccessible. Our development teams are triaging the causer with highest priority presently to restore service as quickly as possible.
Posted Apr 02, 2026 - 10:17 MST
This incident affected: RevolutionParts Platform.